Rewrite code to allow stock version of GLEW

Description

A few changes were made to Ogre's copy of GLEW. It would be better to change the code to work with a stock version of GLEW. I know this is possible, just not sure yet how to do it cleanly.
The advantages we would get:

  • GLEW can be swapped out with a newer version if required.

  • Smaller OGRE libraries

  • glew.cpp triggers tons of compiler warnings when built with Ogre's compile settings.

See also: http://www.ogre3d.org/forums/viewtopic.php?f=3&t=76647

Environment

None

Status

Assignee

Unassigned

Reporter

Former user

Labels

None

Components

Affects versions

Priority

Minor
Configure